Help installing tools on mac

#1

I installed Ruby on Rails, and now am installing metasploit…but when I open terminal and input
cd /opt/metasploit-framework/bin/

to switch open console for msfconsole, nothing happens. Can anyone help/guide me? Thanks.

#2

Follow this method: https://thehacktoday.com/install-metasploit-framework-macos/

That’s an easy way!

#3

Thanks Noor! But when I get to the part in the tutorial, where I open terminal and enter
cd /opt/metasploit-framework/bin/

Nothing happens. Do you or anyone have an idea of whats wrong?

#4

if you just simply type: msfconsole
what you get?

#5

Thanks Noor. I tried that earlier, and got nothing.

#6

My path of installation is

noor-qureshi:~ developer$ /usr/local/bin/msfconsole

Let me know what you get by typing this:

noor-qureshi:~ developer$ which msfconsole

47 AM

#7

Hi Noor,

It just says

command not found

#8

And then says

Joseppis-MacBook-Pro: metasploit-framework joseppi$

#9

Can you retry installing metasploit? And also you didn’t type: which msfconsole

#10

Ah it worked! Thank you!

1 Like
#11

Noor can you private message me?